Benvenuto su VideoMakers.net
Iscriviti per condividere la tua passione sul principale sito web italiano dedicato al VideoMaking!

Gli eventuali inserti pubblicitari all'interno delle discussioni sono visibili solo se non hai eseguito l'accesso al forum; ricordati di eseguire l'accesso o, se non sei ancora registrato, fallo QUI

Clicca qui per leggere le regole del forum
La sezione ufficiale dedicata a Vegas Pro e Vegas Movie Studio HD.

Moderatore: Moderatori

#1326862
Ciao a tutti,
ho dei girati 1920x1080 50i di una telecamera samsung piuttosto datata, che uso in multicamera abbinata alle altre panasonic che ho.
Da quando sono passato da Vegas 17 al 19, le clip girate con questa camera mi danno un problema che non sono riuscito a risolvere in alcun modo: le clip girate in interlacciato al momento del rendering perdono irrimediabilmente questa caratteristica ed è come se diventassero 25p.
Ho messo in questa cartella un breve file originale, e lo stesso file renderizzato col preset Mp4 Magix AVC/AAC da vegas 19 e 17:
https://www.dropbox.com/sh/xqlghj692btz ... oPZ6a?dl=0
Lo stesso identico problema si riscontra anche renderizzando in Mpeg2 con preset per DVD.

Ho visto che su V19 nelle proprietà di progetto non c'è più lo "smart resample" che ho sempre usato di default. In ogni caso ho fatto dei test cambiando tutte le opzioni di resample mode e deinterlace method, ma non ho risolto in alcun modo.
Purtroppo ho fatto due progetti grossi in V19 (compresi anche progetti innestati purtroppo) che naturalmente non riesco a riaprire in V17, ed ho anche tentato avventurosamente dei copia-incolla di timeline ma niente.

Prima di rassegnarmi a tenermi i video così (Full hd 50i con tutti gli stacchi di quella camera che stonano) c'è qualche workaround o possibilità di rimediare?

Ho provato anche la trial del nuovo Vegas 20 ma si comporta esattamente come il 19, quindi se non ci sono novità dovrò continuare ad usare il 17 in presenza di quella camera...

Grazie mille per le eventuali dritte!
#1326868
Ciao Steadi,
ti confermo che analizzando i video risultano entrambi formalmente interlacciati, ma quello uscito da V19 è stato prima deinterlacciato (generando perciò un cosiddetto 25PF). Per produrre un video 25fps interlacciato mantenendone i semicampi si deve usare un progetto 50i e non è necessario applicare alcun resample o deinterlace method. Non posso pensare che V19 non sia in grado di farlo. Piuttosto forse la presenza di altre clip con diverse caratteristiche tecniche hanno richiesto che tu (o Vegas in automatico) cambiassi le impostazioni di progetto. Non dici nulla a proposito delle altre clip quindi non sappiamo se esse siano compatibili con le impostazioni di progetto necessarie per la buona conversione delle clip HDV.

bye
#1326872
CCD ha scritto: mer, 17 ago 2022 - 15:20 Ciao Steadi,
ti confermo che analizzando i video risultano entrambi formalmente interlacciati, ma quello uscito da V19 è stato prima deinterlacciato (generando perciò un cosiddetto 25PF). Per produrre un video 25fps interlacciato mantenendone i semicampi si deve usare un progetto 50i e non è necessario applicare alcun resample o deinterlace method. Non posso pensare che V19 non sia in grado di farlo. Piuttosto forse la presenza di altre clip con diverse caratteristiche tecniche hanno richiesto che tu (o Vegas in automatico) cambiassi le impostazioni di progetto. Non dici nulla a proposito delle altre clip quindi non sappiamo se esse siano compatibili con le impostazioni di progetto necessarie per la buona conversione delle clip HDV.

bye
Ti ringrazio per la risposta.
Nel progetto multicamera uso da svariati anni insieme a questa le stesse camere Panasonic x920 che producono un full HD 50i in formato file Avchd anziché MP4. In ogni caso il progetto è sempre 50i upper field First.

per le clip allegate a questo post ho comunque appositamente aperto un nuovo progetto, vuoto, importando la sola clip originale e accettando le impostazioni di progetto suggerite da Vegas, naturalmente 1920x1080 50i.
Nella cartella di Dropbox c'è anche il file girato originale chiamato HDV, così volendo potreste fare anche voi una prova e vedere se renderizza correttamente....
Grazie
#1326873
Graziaccio ha scritto: mer, 17 ago 2022 - 18:34 Queste le impostazioni di progetto che devi settare.
Impostazioni di progetto.jpg

e questo il template per il rendering
Template di rendering.jpg
Grazie.
Ok per il template rendering che è quello che utilizzo.
Per le impostazioni di progetto, per inciso, se renderizzo in interlacciato mettendo interpolate fields i rallenty mi vengono troppo scattosi, quindi di solito metto blend fields.

Indipendentemente da questo, il problema di cui sopra rimane con Vegas 19. Ho provato tutte le possibili combinazioni degli ultimi due parametri.
Usando Vegas 17 invece tutto ok.
#1326874
Io andrei per esclusione, per capire se è un problema di impostazioni o di software (driver grafici, ecc.). In che modo? Renderizzando la porzione di video utilizzando uno o più codec diversi:

Una prova utile potrebbe essere quella di abilitare il codec MainConcept AVC/AAC, molto simile (ma più datato) al MAGIX AVC/AAC

Per abilitarlo:
1) Tieni premuto il tasto Maiusc, mentre, col mouse clicchi su - Menù/Options
2) Nel menù a discesa clissa su 'Internal'
3) Nella barra 'Show only prefs containing' digita 'Main'
4) Enable Legacy (Mainconcept AVC/AAC and Intel HEVC) è sul valore 'FALSE'. Cambialo, digitando, in 'TRUE'
5) OK. Esci dal programma. Riavvia il software.

Nelle opzioni di rendering, troverai il codec disponibile, abilitato (puoi sempre disabilitarlo facendo il procedimento inverso)

Prova a renderizzare con quel codec. Se il render va a buon fine, è un problema di codec e settaggi, non di software o driver grafici.

Mia curiosità: nel template che utilizzi per il render...
l'Encode mode è MainConcept AVC, Intel QSV O NV Encoder?

Ciao.
#1326875
Graziaccio ha scritto: mer, 17 ago 2022 - 23:29 Io andrei per esclusione, per capire se è un problema di impostazioni o di software (driver grafici, ecc.). In che modo? Renderizzando la porzione di video utilizzando uno o più codec diversi:

Una prova utile potrebbe essere quella di abilitare il codec MainConcept AVC/AAC, molto simile (ma più datato) al MAGIX AVC/AAC

Per abilitarlo:
1) Tieni premuto il tasto Maiusc, mentre, col mouse clicchi su - Menù/Options
2) Nel menù a discesa clissa su 'Internal'
3) Nella barra 'Show only prefs containing' digita 'Main'
4) Enable Legacy (Mainconcept AVC/AAC and Intel HEVC) è sul valore 'FALSE'. Cambialo, digitando, in 'TRUE'
5) OK. Esci dal programma. Riavvia il software.

Nelle opzioni di rendering, troverai il codec disponibile, abilitato (puoi sempre disabilitarlo facendo il procedimento inverso)

Prova a renderizzare con quel codec. Se il render va a buon fine, è un problema di codec e settaggi, non di software o driver grafici.

Mia curiosità: nel template che utilizzi per il render...
l'Encode mode è MainConcept AVC, Intel QSV O NV Encoder?

Ciao.
ciao, ti ringrazio innanzitutto per la disponibilità nel propormi questi test da fare.
Ho provato ad abilitare il codec Mainconcept, ma il risultato del rendering è lo stesso purtroppo.
Ulteriore prova che ho fatto è renderizzare con altri due template dati come "match project settings":
- col template Sony AVC/MVC in formato AVCHD 50i
- AVI (video for windows)
ed il risultato non cambia purtroppo.
La cosa strana è appunto come sulla stessa macchina possano esserci eventuali problemi di driver grafici quando facendo la stessa operazione con vegas17 funziona normalmente.


Venendo all'ultima domanda, il template per il render è Mainconcept AVC H264_CBR .
Ho provato a cambiare in NV encoder e il risultato è lo stesso (ma peraltro il rendering è molto più veloce!).
Intel QSV me lo dà come opzione solo col template MAGIX HEVC/AAC che però lavora solo col 50p e non col 50i.
#1326876
Bene. Sappiamo che non è un problema di singolo codec e/o impostazioni errate.
Purtroppo può succedere che, fra versioni diverse, i driver grafici siano più o meno performanti.

Altri test che puoi fare:

1) Renderizza AVI uncompressed, ricarica il video ottenuto e comprimi col codec MAGIX. Vedi che succede.

2) Dalle preferenze, disabilita l'accelerazione GPU e renderizza. Vedi che succede.

3) Ripulisci la cache di Vegas. Come? Tenendo premuto CTRL + shift in fase di avvio del software. Ti chiederà di ripulire la cache. Attenzione, perché resetterà anche eventuali preferenze e settaggi. Però, spesso, risolve.

Il software, sicuramente, è autentico. Giusto? Altrimenti il problema è quello.

Ciao.
#1326877
Da ciò che hai scritto anche io penso che non ci siano più dubbi circa le impostazioni del tuo lavoro, e mi sembra anche molto difficile che le altre possibilità citate possano davvero risolvere un problema che secondo me nasce dalla gestione che Vegas19 fa del progetto, che per quanto conosco è indipendente dai codec di rendering usati e quindi non aggirabile.
Credo che in questi casi non si possa far altro che segnalare il bug al team di supporto Magix e sperare in un fix veloce nella prossima build.

Mi viene però in mente un tentativo di temporaneo workaround. Se ho ben capito il problema si presenta solo con le clip HDV e non con le clip AVCHD. Se è vero, prova allora a convertire le prime nel secondo tipo (non con Vegas, usando le impostazioni di massima qualità possibile) e reinseriscile nel progetto Vegas (di prova) per il render finale

bye

Below are the attributes of 2k23 mt the Stephe[…]

Dark Matter JRSmithDark 2K MT matter JR Smith […]

Making the most of OSRS gold the Blast Furnace […]

Mentre Iachidda mi ha segnalato che è uscit[…]